Connection drops with wireless dlink router

3 posts / 0 new
Last post
Popeye
Connection drops with wireless dlink router

I have a Dlink DIR-628 router and I am using a MacBook Pro PC. I have recently bought the router. I am using Firmware version 1.24NA and my hardware version is A2. I have been experiencing random wireless connection drop outs. I have tried to reset my router, after which my Internet stays stable for about half an hour and then again the disconnections occur. But, my wired Internet, that is, when I connect the ethernet cable it works fine. At other times, it shows a list of the available connections which it shouldn't as the router is set very near to my laptop. If this was only my problem, I wouldn't have ruled out laptop problems. But, my roommate who is also sharing the same router is experiencing the same problems. My wireless settings are given below.

  • The transmit power is set to high
  • Beacon period is 20
  • WLan partition is unchecked
  • WMM enable is checked
  • Short GI is checked
  • Wi-Fi protection is on
  • Secure spot is on
  • UDP and TCP Endpoint filtering set to Endpoint Independent
  • Port forwarding set to nothing
  • Band is 2.40GHz
  • Enable auto channel scan is checked
  • Wireless radio is enabled
  • 802.11 mode : mixed 802.11n, 802.11g and 802.11b
  • Channel width is 40MHz
  • Channels are 6
  • Secondary channels are 2
  • Wi-Fi- protected setup is enabled/configured
  • Advanced DNS is disabled

Can you help me solve this problem?

Offia_ken
You can try following the

You can try following the steps I have given below.

  • Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
  • Turn on DNS Relay under Setup/Networking.
  • Setup DHCP reserved IP addresses for all devices ON the router under Setup/Networking.
  • Ensure devices are set to auto obtain an IP address.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking.
LuckON
I think you should try single

I think you should try single mode G or mixed G and N. Mostly, the preferred security is WPA-Personal, try changing it to WPA2, Auto TPIK and AES. Some of the WiFi adapters donot support, in such a case you can try TPIK only. If there are many people using WiFi in your area then this might be the reason that may cause connection drop outs. If your current router supports 2.4GHz then you should buy a new router, for instance DIR-825 which supports 5GHz or else you can go for wired connection. It is essential that you turn off the anti-virus and the firewalls when you are testing your PC. You also need to check the cable between modem and router and see that it is on cat6 which is recommended.